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This document is meant to be a simple guide for inexperienced users on how to carry out a basic GIS 

task with SPRING GIS, a program that is available for free. The user will learn how to download and use 

satellite images that are needed from the USGS GloVis website. It will be explained to the user how to 

import and visualize the data into SPRING GIS and how to calculate the NDVI (Normalized Difference 

Vegetation Index) in order to illustrate land cover changes and to monitor droughts. 

The UN Spider team put emphasis on the fact that the single steps are explained and implemented with 

pictures so that no prior knowledge of GIS and related software is required in order to get good results. 

 

Downloading data from GloVis 

At the beginning, satellite imagery data has to be downloaded from websites such as GloVis. It provides 

satellite images for free from various satellites such as Landsat or Modis and from different years.  

-> Open your web browser and type http://glovis.usgs.gov   

You need to have the free java software installed on your computer in order to run GloVis. Now you will 

see the main screen of GloVis. (Picture 1) 

Picture 1 

The main window in the centre contains the map and is split into several rectangular satellite images. 

The one that is selected is highlighted in green or yellow. In order to get a better sense of orientation, 

the button “cities” should be turned on.  

-> map layers -> cities (Picture 2) 

http://glovis.usgs.gov/


  

Picture 2 

 

Now, larger cities are marked on the map in yellow. In this example, we use satellite data of Guatemala. 

To easily locate the country, please click on the small map in the upper left corner and navigate to 

Central America. Alternatively, you can type in for path “20” and for row “50”, this will directly show the 

respective area. (Picture 3) 

 

Picture 3 



 

In the next step, we select a satellite image to be displayed. Click on the “Collection” button and then 

“Landsat Legacy Collections” and choose “ETM+ (1999-2003)” in order to visualize data from Landsat 

ETM from the years 1999 to 2003.  

-> Collection -> Landsat Legacy Collections -> ETM+ (1999-2003) (Picture 4)  

 

Picture 4 

Next, we use the option “Max Cloud” to choose a low cloud cover in order to get a better quality image. 

In the drop down menu, we click on 10%. Observe that the month and year might change as not for 

every date an image with a 10% cloud cover is available. 

-> Max Cloud -> 10% (Picture 5) 

 

Picture 5 



 

After that we select the date we are interested in. In our example we use a satellite image from January 

2000.  

Your screen should now look similar to this: (Picture 6) 

 

Picture 6 

The city names are displayed, the date is changed to January 2000 and the image of row 20 and path 50 

is selected and highlighted in yellow. 

If you want to get a list of the metadata, including projection type or coordinates, do a right-click on the 

image that is highlighted with a yellow rectangular square and choose metadata.  

-> Show Metadata (Picture 7) 



 

Picture 7 

 

The next step is to download the data through clicking on the button “add” in the user interface on the 

left.  -> Add (Picture 8) 

 

Picture 8 

Now your Landsat satellite image is added to the box and you should click on “Send to Cart”, which 

opens a new window.  

-> Send to Cart (Picture 9)  



 

Picture 9 

 

However, you need an account in order to download the satellite data. If you don’t have one yet, you 

need to register. But that’s a fast and simple process. (Picture 10)

 

Picture 10 

After signing in successfully, you will see your item basket with the data that was just added. (Picture 11) 



 

Picture 11 

 

Now click on the button under “Bulk Download” and then on “Apply”.  

-> Bulk Download -> Apply (Picture 11). 

Afterwards the view will change to “Bulk Download” and you can select the data sets that you would like 

to use. Here is just the “Standard Format” available. In other data sets for example, there are also small 

data size Landsat Look images available in jpeg format. But they are not suitable for our NDVI 

calculation. So we always have to select and download the larger Level 1 Product file or in our case the 

Standard Format.  

-> Proceed To Checkout (Picture 12) 

 

Picture 12 

The next screen shows the selected data and its size. Simply click on “Submit Order”.  



-> Submit Order (Picture 13) 

 

Picture 13 

 

Now, we have to wait a while till we can use the satellite imagery. Sometimes it will take several hours 

for the data to be available for download. The “Bulk Download” window provides information on how to 

proceed. You will be notified through email when the data is ready for download. For downloading you 

need the Bulk Download Application that can be installed through clicking on the link that is highlighted 

in the text. (Picture 14) 

 

Picture 14 



Another way to get data is to click on the “File” button in the main menu and then on “Download Visible 

Browse and Metadata”. But this will just download data in the jpeg format and is not suitable for image 

processing or calculating the NDVI. It might just serve for visualization purposes. (Picture 15) 

 

Picture 15 

But once our data request is available for download (check your email account or the Bulk Download 

Application), we got everything we need to get started with SPRING GIS.  

 

 

 

 

 

 



Using SPRING GIS 

Now we have to download Spring GIS, a free GIS program that is developed in Brazil. First of all, type 

http://www.dpi.inpe.br/spring/ in your web browser to open their website. Then please select 

“English”. Your screen will look like this. (Picture 16) 

 

Picture 16 

Click on the button “Downloads” in the upper left corner.  

http://www.dpi.inpe.br/spring/


In the download section you will see the system requirements of SPRING GIS. It can be used on Windows 

and Linux and older computers in general, as the system requirements are quite low. If clicking on the 

“Manuals” button, you will be able to download different Tutorials offered by SPRING. This might be 

helpful if you want to go further into the usage of SPRING GIS. (Picture 17)

 

Picture 17 



You are asked to subscribe through giving your email address in order to download the program. Type in 

your email address and password and select the version of Spring that you want to use, then click on 

subscribe. (Picture 18)

 

Picture 18 

Now you will be directed to the download section where you can choose which language SPRING shall 

be using. You can also choose from which source you want it to be downloaded, but we recommend to 

choose the first one. In our guide we are using the English version so please select the English one and 

click on “Install Complete” in the first section from “DPI – INPE – BRAZIL”. (Picture 19)  

-> Install Complete (English) 

 

Picture 19 



By now the file of around 105MB is downloading. When finished go through the installation setup and 

install the software. (Picture 20) 

 

Picture 20 

 

Now you have SPRING GIS installed and we are ready to proceed with working on our data that we 

downloaded from GloVis earlier. To start, please open SPRING GIS. We basically have to follow three 

steps which include creating a database, then a project and finally a data model. In the beginning we 

need to create a new database. The database is one of the main functions in SPRING GIS and is 

important, because without we cannot really work on data. In the upper left corner we click on file and 

then on database. (Picture 21) 

 -> File -> Database 



 

Picture 21 

 

In the new window we click on the button “directory” and select or create a folder we want to work in. 

Then we give our database a name, such as “course”. To do so type in “course” just next to name and 

click “create”. Now our new database appears as “course”. Finally, we click on “apply”. (Picture 22) 

-> Directory -> name -> create -> apply 

  

Picture 22 



The next step is to define/ create a data model in the active database before we can import any data 

into SPRING. Click on the “file” button and then select “data model”. After that choose “CAT_Image” 

and click on “Execute” which finishes the second step.  

-> File -> data model –> CAT_Image -> Execute (Picture 23) 

 

Picture 23 

 

The last step is to create a “project” that is basically your working platform. You can have various 

projects created, but just one can be active at a time. The project will contain several “Information 

Layers (IL). Please click on the “File” button again and then on “Project” and on the other “Project” 

button as well.  

-> File -> Project -> Project (Picture 24) 



 

Picture 24 

 

In the new window that just opened we name our project for example to “turorial”. Then we have to 

select a projection. Because the data we downloaded is about Central America, we select UTM/Datum 

“SAD69”. Afterwards we click on “Create” and then “Load” at the bottom of the window.  

-> Name -> Projection -> UTM/Datum SAD69 -> Create -> Load (Picture 25) 



  

Picture 25 

 

Finally we have set up everything we need to start working with our satellite imagery data. SPRING GIS 

should look very blank now. The software might look quite complicated at first but for our task we do 

not need to use every function and can concentrate on the most important ones. (Picture 26) 



 

Picture 26 

 

To import our data, please click on the “File” tab and then select “Import” and “Import Vectorial and 

Matricial Data”  

-> File -> Import -> Import Vectorial and Matricial Data (Picture 27) 

 

Picture 27 



Now the “Import” window will be open. Click on “File” and look for the folder in which you saved the 

satellite data from GloVis.  

-> File (Picture 28) 

 

Picture 28 

  

You should change the “files of type” to “Tiff/GEOTIFF because our downloaded data is saved in this 

format and we might not find it otherwise.  

-> Files of Type -> TIFF/GEOTIFF (Picture 29) 

  



 

Picture 29 

 

Here we can see the different Landsat bands listed. For our task we just need the four bands, nn10.tif to 

nn40.tif. Please select them through pressing “Crtl” on the keyboard and clicking on them. Then choose 

“Open” and after that “Apply”. The bands will be loaded into SPRING. This may take several minutes.  

->nn10.tif – nn40.tif -> Open -> Apply (Picture 30) 

 

Picture 30 



A new window will pop up, just click on “OK”. (Picture 31) 

 

Picture 31 

 

When the data is finally loaded you will see the new Information Layers appearing on the left. (Picture 32) 

 

Picture 32 

 

Once the data is imported we can almost start calculating the NDVI. If you click on any Information Layer  

you will be shown the different options. G stands for green, B for blue and R for red. In order to create a 



natural color image we simply select the respective bands with the appropriate color. For the first band 

we select B, for the second one G and for the last band R. The first band is nn10. (Picture 33) 

 

Picture 33 

The band nn10 is activated and a “B” is written at the front. We are also shown a blue image, but it is 

hard to recognize anything on it.  

Now select G for the nn20 one. (Picture 34) 

 

Picture 34 



After that we select the nn30 band and click R for red. Our satellite image is now a natural color one and 

should look more familiar to us. (Picture 35) 

 

Picture 35 

 

So now Spring GIS shows the natural color image. You might have to zoom in a bit to get a closer look at 

the image. The two buttons for doing so are at the top. With the “Roaming Cursor” you can change your 

view and move the image and with the “Magnifier” button next to it on the right you can zoom in. The 

red arrow “Reset” zooms out to a full extent. (Picture 36) 



 

Picture 36 

 

On the upper left corner of the image you are able to see the lake “Lago de Atitlan” and on the left side 

there is Guatemala City visible. 

You can simply try out other band combinations like creating a false color image. To do that please 

choose for the second band (nn20) B, for the third one (nn30) G and for the last one which is the near 

infrared band (nn40) please choose R.  Your satellite image should look like the following. (Picture 37) 



 

Picture 37 

 

To calculate the NDVI index, we first of all click on the “Image” tab and there we select “Arithmetic 

Operations”.  

-> Image -> Arithmetic Operations (Picture 37) 

 



 

Picture 37 

 

The window “Arithmetic Operations” just openend. There we click on the “Operation” button and select 

“C=Gain*((A-B)/(A+B))+Offset. (Picture 38) 

 

Picture 38 



After that we select the band nn40 for A and nn30 for B. (Picture 39) 

 

Picture 39 

 

Output C can be just named “ndvi”. In the dropdown menu we select 32. Finally we click on “Apply” and 

the NDVI will be calculated. This may take a while. When the operation is done there should be a new 

window called “Assistant” popping up. A new Information Layer called “ndvi” will be there, marked with 

an “m”. You probably have to zoom in a bit. Alternatively you could close the “Assistant” window and 

just work in the original one. However, we should have a similar outcome as in the following picture. 
(Picture 40)  



 

Picture 40 

Congratulations. The NDVI is calculated. White areas symbolize regions where vegetation is active and 

growing, darker areas show parts where there is less, dead or not active vegetation. You can zoom in 

and explore a bit the data we just created. For a better reference, we can color the image by clicking on 

the “Color Pallet” button at the top of the screen.  

-> Color Pallet (Picture 41) 

 

Picture 41 

 

 



Select a color scale that seems useful to you. Areas with dense and active vegetation would be in dark 

green according to the color mapping in our example and areas with less vegetation will be marked in 

white or even pink. Click on “Finish” (Picture 42) 

 

Picture 42 

 

Our calculated NDVI image should look similar to the following one. Note that Guatemala City looks very 

white, as there are not many plants compared to other areas. Same applies for the big lake.  (Picture 43) 

 

Picture 43 



We finally got our end result. Taking data from various dates over a large time span and calculating the 

NDVI out of every single one would easily show the change of vegetation cover over time and would be 

a helpful tool in land use change and drought monitoring. 


